Pangomm-2.46.0

Introduction to Pangomm

The Pangomm package provides a C++ interface to Pango.

This package is known to build and work properly using an LFS-10.1 platform.

Package Information

Pangomm Dependencies

Required

libcairomm-1.14.0, GLibmm-2.66.0 and Pango-1.48.4

User Notes: https://wiki.linuxfromscratch.org/blfs/wiki/pangomm

Installation of Pangomm

Install Pangomm by running the following commands:

mkdir build &&
cd    build &&

meson --prefix=/usr .. &&
ninja

This package does not come with a test suite.

Now, as the root user:

ninja install

Contents

Installed Programs: None
Installed Library: libpangomm-1.4.so
Installed Directories: /usr/include/pangomm-1.4, /usr/lib/pangomm-1.4, and /usr/share/{devhelp/books/pangomm-1.4,doc/pangomm-2.46.0}

Short Descriptions

libpangomm-1.4.so

contains the Pango API classes

Last updated on Tue Apr 20 18:52:06 2021